Can not running on my Xcode....sadly

BASIC SDK для Xcode
vincent
Posts: 3
Joined: Fri Jan 04, 2019 3:33 pm
Flag: Taiwan

Can not running on my Xcode....sadly

Post by vincent »

:(
Maybe I need the older version xcode.
Or reconfig it again.
Any suggestion ?

User avatar
Mr. Kibernetik
Site Admin
Posts: 4596
Joined: Mon Nov 19, 2012 10:16 pm
My devices: iPad, iPhone, MacBook
Location: Russia
Flag: Russia

Re: Can not running on my Xcode....sadly

Post by Mr. Kibernetik »

BASIC SDK was tested on Xcode 7.

vincent
Posts: 3
Joined: Fri Jan 04, 2019 3:33 pm
Flag: Taiwan

Re: Can not running on my Xcode....sadly

Post by vincent »

Ok, I will test it again. On my latest IDE.

User avatar
GeorgeMcGinn
Posts: 435
Joined: Sat Sep 10, 2016 6:37 am
My devices: IPad Pro 10.5in
IMac
Linux i386
Windows 7 & 10
Location: Venice, FL
Flag: United States of America
Contact:

Re: Can not running on my Xcode....sadly

Post by GeorgeMcGinn »

I know it works on version 7 and version 8.

I have version 8'and you can set your XCode to a prior version for testing. I do a lot of backward compatibility testing as part of my software process.
George McGinn
Computer Scientist/Cosmologist/Writer/Photographer
Member: IEEE, IEEE Computer Society
IEEE Sensors Council & IoT Technical Community
American Association for the Advancement of Science (AAAS)

vincent
Posts: 3
Joined: Fri Jan 04, 2019 3:33 pm
Flag: Taiwan

Re: Can not running on my Xcode....sadly

Post by vincent »

Hi George,
Thank you for your work.
:D

Vincent Lin ;)

User avatar
GeorgeMcGinn
Posts: 435
Joined: Sat Sep 10, 2016 6:37 am
My devices: IPad Pro 10.5in
IMac
Linux i386
Windows 7 & 10
Location: Venice, FL
Flag: United States of America
Contact:

Re: Can not running on my Xcode....sadly

Post by GeorgeMcGinn »

I wonder if with the new Xcode whether we will ever be able to create apps again as the version of the SDK has not been updated in almost 2 years, another words it's predates iOS so 11 and 12.

Before my iMac crapped out on me, a lot of the simple their coding statements such as SLIDER statement no longer worked in Xcode, and Apple's development support said it was because the SDK was not in sync with what has been currently developed in the new iOS releases.

Unless this is remedied, I fear that the problem will only get worse as Apple continues to develop and change the way statements work as Mr. K is no longer supporting this product which means the SDK is no longer been updated as well.

Good luck come in if you need some help you can PM me.




vincent wrote:
Sat Feb 23, 2019 4:46 pm
Hi George,
Thank you for your work.
:D

Vincent Lin ;)
George McGinn
Computer Scientist/Cosmologist/Writer/Photographer
Member: IEEE, IEEE Computer Society
IEEE Sensors Council & IoT Technical Community
American Association for the Advancement of Science (AAAS)

User avatar
Mr. Kibernetik
Site Admin
Posts: 4596
Joined: Mon Nov 19, 2012 10:16 pm
My devices: iPad, iPhone, MacBook
Location: Russia
Flag: Russia

Re: Can not running on my Xcode....sadly

Post by Mr. Kibernetik »

Smart BASIC SDK is just an Xcode project and can be updated to current Xcode version.

User avatar
GeorgeMcGinn
Posts: 435
Joined: Sat Sep 10, 2016 6:37 am
My devices: IPad Pro 10.5in
IMac
Linux i386
Windows 7 & 10
Location: Venice, FL
Flag: United States of America
Contact:

Re: Can not running on my Xcode

Post by GeorgeMcGinn »

I will look into this, but my new question is do we need a new SDK for the new version of SmartBASIC?

I ask because I see the old SDK has Dropbox in it, and I can remove it, but I am not sure how compatible your new upgrades to your software's compatibility to iOS will need a SDK upgrade.

Thanks.

George


Mr. Kibernetik wrote:
Thu Jun 06, 2019 7:07 am
Smart BASIC SDK is just an Xcode project and can be updated to current Xcode version.
George McGinn
Computer Scientist/Cosmologist/Writer/Photographer
Member: IEEE, IEEE Computer Society
IEEE Sensors Council & IoT Technical Community
American Association for the Advancement of Science (AAAS)

User avatar
Mr. Kibernetik
Site Admin
Posts: 4596
Joined: Mon Nov 19, 2012 10:16 pm
My devices: iPad, iPhone, MacBook
Location: Russia
Flag: Russia

Re: Can not running on my Xcode

Post by Mr. Kibernetik »

GeorgeMcGinn wrote:
Thu Nov 19, 2020 6:46 pm
I ask because I see the old SDK has Dropbox in it, and I can remove it, but I am not sure how compatible your new upgrades to your software's compatibility to iOS will need a SDK upgrade.
New BASIC SDK has no Dropbox in it.

User avatar
GeorgeMcGinn
Posts: 435
Joined: Sat Sep 10, 2016 6:37 am
My devices: IPad Pro 10.5in
IMac
Linux i386
Windows 7 & 10
Location: Venice, FL
Flag: United States of America
Contact:

Re: Can not running on my Xcode

Post by GeorgeMcGinn »

Is the new version of the SDK available using the old link, or is there a new link to it? (In the meantime I will try the old link and look at it(

George.
Mr. Kibernetik wrote:
Thu Nov 19, 2020 6:53 pm
GeorgeMcGinn wrote:
Thu Nov 19, 2020 6:46 pm
I ask because I see the old SDK has Dropbox in it, and I can remove it, but I am not sure how compatible your new upgrades to your software's compatibility to iOS will need a SDK upgrade.
New BASIC SDK has no Dropbox in it.
George McGinn
Computer Scientist/Cosmologist/Writer/Photographer
Member: IEEE, IEEE Computer Society
IEEE Sensors Council & IoT Technical Community
American Association for the Advancement of Science (AAAS)

Post Reply